Issue with Mighty Insights

Incident Report for Mighty Networks

Resolved

We quickly identified the cause and have resolved this issue.
Posted Jun 24, 2025 - 14:01 UTC

Investigating

We are currently experiencing an issue where data is not loading in Mighty Insights. We are investigating this issue now.
Posted Jun 24, 2025 - 13:55 UTC
This incident affected: Analytics (Mighty Insights).