Errors when loading some profile pages with tags and badges on Web
Incident Report for Mighty Networks
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 22:33 UTC
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 22:09 UTC