Issue with navigation on mobile web browsers
Incident Report for Mighty Networks
Resolved
We experienced an issue with a percentage of traffic navigating on mobile web browsers. The issue has since been resolved.
Posted Apr 24, 2024 - 15:30 UTC