Issue with Livestreams that may have impacted the ability to join
Incident Report for Mighty Networks
Resolved
New attendees may have experienced an error when trying to join Livestreams with 2000+ attendees
Posted Oct 03, 2023 - 23:51 UTC