Newly uploaded images are not rendering

Incident Report for Mighty Networks

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 00:06 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 13, 2025 - 00:05 UTC

Monitoring

Good news! We believe this to be resolved.

In all our tests, newly uploaded images now display properly. We will continue to monitor.

More information about this broad outage is also available here https://www.tomsguide.com/news/live/google-cloud-down-jun-12-outage
Posted Jun 12, 2025 - 20:24 UTC

Update

Here is the Google Incident. They are still working on a fix https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 20:17 UTC

Update

We're learning many sites across the internet are affected (see https://downdetector.com/), likely related to a Google Cloud outage (though they have not yet updated their status page, possibly due to the outage.

So far, this appears to only affect the ability to upload new images.
Posted Jun 12, 2025 - 18:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 18:18 UTC

Investigating

Our provider for delivering images (ImgIX) is having issues with newly uploaded images. They have identified the issue and are working on a fix. For more details, see:
https://status.imgix.com/

This does not affect existing images and all uploaded images will render properly as soon as they have resolved the issue.
Posted Jun 12, 2025 - 18:17 UTC
This incident affected: Media (Image Rendering).