Issue with Email Provider
Incident Report for Mighty Networks
Resolved
This incident has been resolved.
Posted Nov 01, 2023 - 03:04 UTC
Monitoring
A fix has been implemented and is being montiroed.
Posted Nov 01, 2023 - 02:45 UTC
Identified
The issue has been identified by Mailgun
Posted Nov 01, 2023 - 02:23 UTC
Investigating
Our third-party email provider, Mailgun, is experiencing an outage that may result in failed email delivery to addresses in the EU region. They are currently investigating the situation.
Posted Nov 01, 2023 - 01:21 UTC
This incident affected: Notifications (mailgun Outbound Delivery).