Issues with Mighty Insights
Incident Report for Mighty Networks
Resolved
This incident has been resolved. Mighty Insights is loading correctly.
Posted Apr 17, 2024 - 19:31 UTC
Investigating
We are currently experiencing an issue where Insights are not loading. We are investigating this issue now.
Posted Apr 17, 2024 - 13:15 UTC
This incident affected: Analytics (Mighty Insights).