Issues with members joining Plan Access Networks

Incident Report for Mighty Networks

Resolved

We have resolved this issue. If you're still seeing the issue, refresh your browser and try again.
Posted Apr 21, 2025 - 17:26 UTC

Monitoring

We have implemented a fix and will monitor.
Posted Apr 21, 2025 - 17:09 UTC

Investigating

We are experiencing an issue where some buttons on Plan Access Network landing pages are not navigating users to plans to purchase. We are currently investigating the cause of this issue. New members are still able to join by scrolling down and clicking on plans.
Posted Apr 21, 2025 - 16:35 UTC
This incident affected: Networks (Web App).