Delayed Emails
Incident Report for Mighty Networks
Resolved
Mailgun has resolved this issue.
Posted Oct 01, 2024 - 00:42 UTC
Identified
Our email provider, Mailgun, is experiencing an outage resulting in a small fraction of emails being delayed or not sent at all. Mailgun is implementing a fix for this issue.
Posted Sep 30, 2024 - 23:55 UTC
This incident affected: Notifications (mailgun API, mailgun SMTP, mailgun Outbound Delivery).