No components marked as affected
Resolved
This issue has now been resolved. Image uploads, previews, and image display across the platform are working normally again.
Identified
We're currently seeing intermittent errors with images. Uploading new images, image previews, and existing images may not work or display correctly across the platform.
This is being caused by an outage with a third-party CDN/storage provider. Our team is actively monitoring the situation.