Some videos are failing to load
Resolved·Partial outage

We've restored access to the final videos, all affected videos are now available.

Mon, Feb 16, 2026, 07:45 PM
(6 days ago)
·
Affected components
Updates

Resolved

We've restored access to the final videos, all affected videos are now available.

Mon, Feb 16, 2026, 07:45 PM

Identified

We are currently experiencing an issue where videos may fail to play, affecting 10% of videos. We have restored functionality to about 90% of affected videos, and work is ongoing to restore full functionality. We expect full resolution by end-of-day and will provide further updates as progress continues.

Mon, Feb 16, 2026, 06:08 PM(1 hour earlier)

Identified

We are currently experiencing an issue where videos may fail to play, affecting 10% of videos. We have restored functionality to about 80% of affected videos, and work is ongoing to restore full functionality. We expect full resolution by end-of-day and will provide further updates as progress continues.

Mon, Feb 16, 2026, 12:03 PM(6 hours earlier)

Identified

We are currently experiencing an issue where videos may fail to play, affecting 10% of videos. We have restored functionality to about 60% of affected videos, and work is ongoing to restore full functionality. We expect full resolution by tomorrow and will provide further updates as progress continues.

Sun, Feb 15, 2026, 11:00 PM(13 hours earlier)

Identified

We are currently experiencing an issue where videos may fail to play, affecting 10% of videos. We have restored functionality to about 40% of affected videos, and work is ongoing to restore full functionality. We expect full resolution by tomorrow and will provide further updates as progress continues.

Sun, Feb 15, 2026, 02:45 PM(8 hours earlier)

Investigating

We are aware that some videos are failing to load, we are actively investigating.

Sat, Feb 14, 2026, 04:25 PM(22 hours earlier)