Issue with delayed notifications & uploads

Incident Report for Mighty Networks

Resolved

This issue has been resolved.
Posted Oct 21, 2025 - 12:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 12:28 UTC

Identified

Our partner has narrowed down the issue and is working to resolve it.
Posted Oct 20, 2025 - 21:30 UTC

Investigating

We are experiencing an issue with a vendor we work with that is causing some significant delays on notification delivery and with media uploads on the platform. We are looking into what we can do on our side while the vendor resolves any issues on theirs.
Posted Oct 20, 2025 - 16:16 UTC
This incident affected: Notifications (Email Delivery, Push Notifications, In-app Notifications) and Media (Video Uploading).